Power Outage - Partial
Incident Report for Village of Merrillan
Postmortem

Bunting Ln trees went down on lines again.

It is possible additional outages may occur as more trees fall from additional snowfall, wind, and other pressures.

Posted Dec 18, 2022 - 07:00 CST

Resolved
The Village is experiencing power outages in areas. We are investigating.
Posted Dec 17, 2022 - 15:00 CST