Power Outage - Blackout
Incident Report for Village of Merrillan
Resolved
Resolved. Tree on Jackson Electric line along Jeffrey Rd.
Posted Jun 01, 2023 - 13:29 CDT
Investigating
The Village as a whole is currently without power. We are looking into the matter and/or staff is working on the issue including other service providers that feed the Village. Outage cause could be within the Village, through Jackson Electric, or further down the line.
Posted Jun 01, 2023 - 12:29 CDT
This incident affected: Electric Utility.