Power Outage - Partial/Intermittent
Incident Report for Village of Merrillan
Resolved
Power has been restored.
Posted Apr 19, 2023 - 13:37 CDT
Identified
The Village is experiencing power outages in the area of Bunting Ln and Lower Lake. There are trees down on power lines from the wind. We are actively working on a resolution but recent weather and the challenging location of the outage may delay restoration.
Posted Apr 19, 2023 - 10:37 CDT
This incident affected: Electric Utility.