Power Outage - Blackout
Incident Report for Village of Merrillan
Postmortem

Outage on Jackson Electric’s end.

Posted Dec 18, 2022 - 06:53 CST

Resolved
The Village as a whole is currently without power. We are looking into the matte and/or staff is working on the issue including other service providers that feed the Village. Outage cause could be within the Village, through Jackson Electric, or further down the line.
Posted Dec 17, 2022 - 08:30 CST