Power Outage - Blackout
Incident Report for Village of Merrillan
Postmortem

The winter weather caused considerable damage the the electric infrastructure throughout the region. Jackson County was especially affected, including the Village of Merrillan. Being a small Village, we have two full time staff to handle all of our utilities. They worked non-stop to restore power to the Village, assisted by several others in attempting to clear debris and snow from our streets. Other services were delayed due to the priority placed on restoring electricity during the cold winter time that this occurred in. The Village appreciates everyone’s patience and understanding as the Village works through these issues with the resources available to us. Overall considering the amount of work and the time it took to get resolved, the work was done in an extremely expedient and efficient manner.

Posted Dec 18, 2022 - 06:56 CST

Resolved
The Village as a whole is currently without power. We are looking into the matter and will update when available.
Posted Dec 15, 2022 - 00:30 CST