Power Outage - Partial
Incident Report for Village of Merrillan
Resolved
Power has been restored to all residents. If any other issues come up please let us know.
Posted Apr 17, 2023 - 17:04 CDT
Identified
Crews are still working to fix power outages. Heavy snow and wind along with road conditions are making the process longer. Please be patient. Thank you.
Posted Apr 17, 2023 - 12:06 CDT
Update
We are continuing to investigate this issue.
Posted Apr 17, 2023 - 05:28 CDT
Investigating
Bunting Lane and Lower Lake outage. Additional power outages may occur.
Posted Apr 17, 2023 - 02:00 CDT
This incident affected: Electric Utility.