Power Outage - Partial/Intermittent
Incident Report for Village of Merrillan
Postmortem

Bunting Lane

Posted Mar 03, 2024 - 21:27 CST

Resolved
The Village is experiencing power outages in areas. We are looking into the matter and/or staff is working on the issue including other service providers that feed the Village. Outage cause could be within the Village, through Jackson Electric, further down the line, or another issue. We will update as soon as possible. If you are in need of medical attention as a result of the power outage and it is an emergency, please call 911.
Posted Jan 21, 2024 - 10:00 CST