Power Outage - Partial
Incident Report for Village of Merrillan
Resolved
This incident has been resolved.
Posted Nov 16, 2023 - 17:56 CST
Investigating
We are currently investigating this issue.
Posted Nov 16, 2023 - 16:30 CST
This incident affected: Electric Utility.